3 Getting to know your Programming 

Environment 

3.1 Objectives 

In this section, we will be discussing on how to write, compile and run Java programs. There are two ways of doing this, the first one is by using a console and a text editor. The second one is by using Netbeans which is an Integrated Development Environment or IDE. 

At the end of the lesson, the student should be able to: 

 Create a Java program using text editor and console in the Linux environment  Differentiate between syntax-errors and runtime errors 

 Create a Java program using Netbeans 

3.2 Introduction 

An IDE is a programming environment integrated into a software application that provides a GUI builder, a text or code editor, a compiler and/or interpreter and a debugger. 

This tutorial uses RedHat Linux as the operating system. Make sure that before you do this tutorial, you have installed Java and Netbeans in your system. For instructions on how to install Java and Netbeans, please refer to Appendix A. For the Windows XP version of this section, please refer to Appendix B. 

Before going into details, let us first take a look at the first Java program you will be writing. 

3.3 My First Java Program 

public class Hello 

{ 

/** 

* My first java program 
*/ 

public static void main(String[] args) { 

//prints the string "Hello world" on screen 

System.out.println("Hello world!"); 

} 

} 

Before we try to explain what the program means, let's first try to write this program in a file and try to run it. 
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3.4 Using a Text Editor and Console 

For this example, we will be using a text editor to edit the Java source code. You will also need to open the Terminal window to compile and execute your Java programs. 

Step 1: Start the Text Editor 

To start the Text Editor in Linux, click on Menu-> Accessories-> Text Editor. 

Figure 3.2: Text Editor Application in Linux 

Figure 3.1: Opening the Text Editor 
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Step 2: Open Terminal 

To open Terminal in Linux, click on Menu-> System Tools-> Terminal. 

Figure 3.4: Terminal in Linux 

Figure 3.3: Opening the Terminal 
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Step 3: Write your the source code of your Java program in the Text Editor 

Figure 3.5: Writing the Source Code with the Text Editor 
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Step 4: Save your Java Program 

We will save our program on a file named "Hello.java", and we will be saving it inside a folder named MYJAVAPROGRAMS. 

To open the Save dialog box, click on the File menu found on the menubar and then click on Save. 

Figure 3.6: Saving the Source Code 
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After doing the procedure described above, a dialog box will appear as shown in Figure below. 

Figure 3.7: Save As Dialog 
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Now, we'll create a new folder inside the root folder where we will save your programs. We shall name this folder MYJAVAPROGRAMS. Click on the button encircled in the figure below to create the folder. 

A dialog box named "New Folder" will then appear. Type on the "Folder Name" Textbox MYJAVAPROGRAMS, and click on the CREATE button. 

Figure 3.8: Creating New Folder 

Introduction to Programming I
34

[image: image15.jpg]File Edit View Teminal Go Help
[rootelocalhost rootl# s
MYJAVAPROGRAMS

[rootelocalhost root]#

Q root@localhost:~ ’ T
’ [ UrooymY JAVAPROGRAMS He| 1130 AM




[image: image16.jpg]Fle Edt View Teminal Go Help

[rootelocalhost root]# 1s

MYJAVAPROGRAMS

[rootelocalhost root]# cd MYJAVAPROGRAMS/
=] [root@localhost MYJAVAPROGRAMS]# ||

[Broot@localhost:~/MY JAVAPRC|

[/root/MY JAVAPROGRAMS/He|

Tue Apr 05
11:30 AM




J.E.D.I 

Now that we've created the folder where we will save all the files, double click on that folder to open it. 

Figure 3.9: Opening the Created Folder 
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You will see a similar figure as shown below after you clicked on MYJAVAPROGRAMS. The folder should be empty for now since it's a newly created folder and we haven't saved anything in it yet. 

Figure 3.10: View Inside The Created Folder 
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Now, in the Selection textbox, type in the filename of your program, which is "Hello.java", and then click on the OK button. 

Figure 3.11: Saving the Source Code Inside the Created Folder 
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Now that you've saved your file, notice how the title of the frame changes from "Untitled 1 (modified) - gedit" to "/root/MYJAVAPROGRAMS/Hello.java - gedit". Take note that if you want to make changes in your file, you can just edit it, and then save it again by clicking on File -> Save. 

Figure 3.12: New Window After Saving 
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Step 5: Compiling your program 

Now, the next step is to compile your program. Go to the Terminal window we just opened a while ago. 

Typically, when you open the terminal window, it opens up and takes you directly to what is called your home folder. To see what is inside that home folder, type ls and then press ENTER. What you will see is a list of files and folders inside your home folder. 

Figure 3.13: Lists of Files in the Home Folder 

Now, you can see here that there is a folder named "MYJAVAPROGRAMS" which we have created a while ago, and where we saved our Hello.java program. Now let's go inside that directory. 
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To go inside a directory, you type in the command: cd [directory name]. The "cd" command stands for, change directory. In this case, since the name of our directory is MYJAVAPROGRAMS, you type in: cd MYJAVAPROGRAMS 

Figure 3.14: Changing the Directory 
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Once inside the folder where your Java programs are, let us now start compiling your Java program. Take note that, you should make sure that the file is inside the folder where you are in. In order to do that, execute the "ls" command again to see if your file is inside that folder. 

Figure 3.15: List of Files Inside the New Directory 
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To compile a Java program, we type in the command: javac [filename]. So in this case, type in: javac Hello.java. 

Figure 3.16: Compiling Java File 

During compilation, javac adds a file to the disk called [filename].class, or in this case, Hello.class, which is the actual bytecode. 
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Step 6: Running the Program 

Now, assuming that there are no problems during compilation (we'll explore more of the problems encountered during compilation in the next section), we are now ready to run your program. 

To run your Java program, type in the command: java 
[filename without the extension], so in the case of our example, type in: java Hello 

You can see on the screen that you have just run your first Java program that prints the message, "Hello world!". 

Figure 3.17: Running Class File 
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3.4.1 Errors 

What we've shown so far is a Java program wherein we didn't encounter any problems in compiling and running. However, this is not always the case. As what we have discussed in the first part of this course, we usually encounter errors along the way. 

As discussed before, there are two types of errors. The first one is a compile-time error or also called as syntax error. The second one is the runtime error. 

3.4.1.1 Syntax Errors 

Syntax errors are usually typing errors. You may have misspelled a command in Java or forgot to write a semi-colon at the end of a statement. Java attempts to isolate the error by displaying the line of code and pointing to the first incorrect character in that line. However, the problem may not be at the exact point. 

Other common mistakes are in capitalization, spelling, the use of incorrect special characters, and omission of correct punctuation. 

Let's take for example, our Hello.java program wherein we intentionally omit the semicolon at one statement and we try to type the incorrect spelling of a command. 

Figure 3.18: Source Code With Errors 
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See the error messages generated after compiling the program. The first error message suggests that there is an error in line 6 of your program. It pointed to the next word after the statict, which should be spelled as static. 

The second error message suggests that there is a missing semicolon after your statement. 

Figure 3.19: Compiling the Source Code with Errors 

As a rule of thumb, if you encounter a lot of error messages, try to correct the first mistake in a long list, and try to compile the program again. Doing so may reduce the total number of errors dramatically. 

3.4.1.2 Run-time Errors 

Run-time errors are errors that will not display until you run or execute your program. Even programs that compile successfully may display wrong answers if the programmer has not thought through the logical processes and structures of the program. 
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3.5 Using Netbeans 

Now that we've tried doing our programs the complicated way, let's now see how to do all the processes we've described in the previous sections by using just one application. 

In this part of the lesson, we will be using Netbeans, which is an Integrated Development Environment or IDE. An IDE is a programming environment integrated into a software application that provides a GUI builder, a text or code editor, a compiler and/or interpreter and a debugger. 

Step 1: Run Netbeans 

There are two ways to run Netbeans. One is through command-line using terminal, or by jst clicking on the shortcut button found on the main menu. 

To run Netbeans using command-line. Open terminal (see steps on how to run terminal in the previous discussion), and type: netbeans 

Figure 3.20: Running Netbeans with the Command-Line 
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The second way to run Netbeans, is by clicking on Menu-> Programming-> More Programming Tools-> Netbeans. 

Figure 3.21: Running Netbeans using the Menu 
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After you've open NetBeans IDE, you will see a graphical user interface (GUI) similar to what is shown below. 

Figure 3.22: Window After Openning Netbeans 
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Step 2: Make a project 

Now, let's first make a project. Click on File-> New Project. 

Figure 3.23: Starting New Project 
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After doing this, a New Project dialog will appear. 

Figure 3.24: Choosing Project Type 
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Now click on Java Application and click on the NEXT button. 

Figure 3.25: Choosing Java Application as Project Type 
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Now, a New Application dialog will appear. Edit the Project Name part and type in "HelloApplication". 

Figure 3.26: Setting the Project Name 
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Now try to change the Application Location, by clicking on the BROWSE button. 

Figure 3.27: Setting the Project Location 
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A Select Project Location dialog will then appear. Double-click on the root folder. 

Figure 3.28: Opening the Root Folder 
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The contents of the root folder is then displayed. Now double-click on the MYJAVAPROGRAMS folder and click on the OPEN button. 

Figure 3.29: Choosing the Folder MYJAVAPROGRAMS as Project Location 
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See now that the Project Location and Project Folder is changed to 
/

root/MYJAVAPROGRAMS.

Figure 3.30: Window after Setting the Project Location to MYJAVAPROGRAMS
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Finally, on the Create Main Class textfield, type in Hello as the main class' name, and then click on the FINISH button. 

Figure 3.31: Setting the Main Class of the Project to Hello 
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Step 3: Type in your program 

Before typing in your program, let us first describe the main window after creating the project. 

As shown below, NetBeans automatically creates the basic code for your Java program. You can just add your own statements to the generated code. On the left side of the window, you can see a list of folders and files that NetBeans generated after creating the project. This can all be found in your MYJAVAPROGRAMS folder, where you set the Project location. 

Figure 3.32: View of the Created Project 
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Now, try to modify the code generated by Netbeans. Ignore the other parts of the program for now, as we will explain the details of the code later. Insert the code: 

System.out.println("Hello world!"); 

after the statement, //TODO code application logic here. 

Figure 3.33: Inserting the Code 
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Step 4: Compile your program 

Now, to compile your program, just click on Build -> Build Main Project. 

Figure 3.34: Compiling with Netbeans Using the Build Menu 

Or, you could also use the shortcut button to compile your code. 

Figure 3.35: Compiling with Netbeans Using the Shortcut Button 
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If there are no errors in your program, you will see a build successful message on the output window. 

Figure 3.36: View after a Successful Compilation 
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Step 5: Run your program 

To run your program, click on Run-> Run Main Project. 

Figure 3.37: Running with Netbeans using the Run Menu 

Or you could also use the shortcut button to run your program. 

Figure 3.38: Running with Netbeans using the Shortcut Button 
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The output of your program is displayed in the output window. 

Figure 3.39: View after a Successful Run 
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3.6 Exercises 

3.6.1 Hello World! 

Using Netbeans, create a class named: [YourName]. The program should output on the screen: 

Welcome to Java Programming [YourName]!!! 

3.6.2 The Tree 

Using Netbeans, create a class named: TheTree. The program should output the following lines on the screen: 

I think that I shall never see, 
a poem as lovely as a tree. 
A tree whose hungry mouth is pressed Against the Earth’s sweet flowing breast. 
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